WoW latency
#1
Anyone else experiencing high latency ?
I've tried all SG and Malaysia gates ,all giving me high ms in game
Reply
#2
Same here. High latency
Reply
#3
Same here having high latency in WoW across all Singapore and Malaysia servers...playing from Malaysia.
Reply
#4
same here. 300-450ms
Reply
#5
Same here, its twice as much.
Reply
#6
Same here, been using battleping for over 2 months and it seems my ping is hovering at 300ms using the sydney 4 server on WoW.

Are the devs aware of the issue?

(10-30-2018, 11:51 PM)myrir Wrote: Same here, its twice as much.
Reply
#7
Same here. I have three proxy programs - BattlePing, WTFast, Pingzapper - and all of their servers have high ping to WoW's oceanic servers. Only Pingzapper's Sydney 1 server gives decent ping at 140ms.

This has been happening since a couple of days ago.
Reply
#8
Hi, there is a routing issue affecting alot of connections, both within Australia and Out when connecting to Wow network.

We will be able to create a workaround for this, but wont be able to have this in place till approximately tomorrow afternoon.
Reply
#9
(10-31-2018, 05:05 PM)Tech Wrote: Hi, there is a routing issue affecting alot of connections, both within Australia and Out when connecting to Wow network.

We will be able to create a workaround for this, but wont be able to have this in place till approximately tomorrow afternoon.

Thanks..Looking forward to this one anyway..Pls keep us posted alright..
Reply
#10
(10-31-2018, 02:24 PM)Gilad Wrote: Same here. I have three proxy programs - BattlePing, WTFast, Pingzapper - and all of their servers have high ping to WoW's oceanic servers. Only Pingzapper's Sydney 1 server gives decent ping at 140ms.

This has been happening since a couple of days ago.

Please! 2 days w/o BPing is a killer zz!
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)