Can't deactivate Battleping ID
#1
Hey, I've been trying to use Battleping again but it initially told me that my username didn't match the ID. So I've been trying to deactivate it but I get hit with a simple "Connection to servers failed." Maybe I should've checked this out before buying a month's worth of time but how can I resolve this issue. I've tried reinstalling it to see if it would just let me start fresh but that didn't work as well.
Reply
#2
Hi there may have been some issue to the activation server since a couple of users had issue, We have tested and made sure its working now, if you still have issue let us know.
Reply
#3
I just checked right now and the problem is still persisting.
Reply
#4
Try putting this file in your Battleping folder and opening it, https://www.battleping.com/setup/TurboActivate.exe
if that does not work also, it must be some network issue or a temporary routing issue, unless something like a firewall blocked it.

You could open the applicaiton once with a vpn to activate it, or email support@battleping.com and we can give you access to a VPN that should bypass the connection to server issue.
Reply
#5
Thank you for your help. I tried using my phone's WIFI hotspot to try to deactivate and it worked.
Reply
#6
Thanks for your reply, Im unsure of the cause as the Activation/Deactivation server is online when we are testing.
I'm sorry you had the trouble today.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)